Dependency Conflict in React APP.

Nowadays, I worked on two existing project that use material UI. While installing module, I got this error. So I tried to install by force or legacy-peer-deps. This kind of installing will impact scalable and robust project? What is the best solution for dependency conflict issue ?
No description
UU
Unknown User226d ago
A
ACE226d ago
Thank you
UU
Unknown User225d ago